如何在CentOS、RHEL、Fedora、Mandriva中安装和升级RPM软件包

rpm 是RHEL、CentPOS、Fedora和Mandriva等流行发行版使用的包格式。我们通常喜欢使用 yum 命令从互联网上安装软件包自动和方便。在某些情况下,我们可能需要单独安装rpm包。在本教程中,我们将了解如何解决依赖关系并安装rpm包。

西门子APT按钮金属自锁自复位启动紧急开关LA39-B2-11 02/RBG红绿
| 月销量109件
优惠价11元
原价¥60

淘口令:

¥1F4HXSoF0I0¥
 

Linux Rpm命令及其示例

下载RPM软件包

我们可以从不同的来源获得RPM文件。在旧时代,RPM通常提供CD或软盘,但今天互联网是事实上的来源,以获得RPM文件。我们可以使用以下站点搜索和下载不同发行版、体系结构的RPM文件。

http://rpm.pbone.net

在这个exmaple中,我们将用wget下载RPM文件。

$ wget ftp://mirror.switch.ch/pool/4/mirror/centos/7.4.1708/updates/x86_64/Packages/iptables-utils-1.4.21-18.2.el7_4.x86_64.rpm
Download RPM Package
下载RPM软件包

列出RPM包依赖项

正如我们所知,包通常需要一些库和其他包来相应地工作。这称为包依赖关系。我们应该列出包依赖关系,以检查系统是否满足所需的包。

$ rpm -qpR iptables-utils-1.4.21-18.2.el7_4.x86_64.rpm
List RPM Package Dependencies
列出RPM包依赖项

如我们所见,有一些依赖项,如libc、libnfnetlink等。

安装RPM

现在我们假设已经安装了所需的依赖项并准备好安装下载的RPM包。我们将提供 -ivh 选项和RPM包名称 rpm 命令。我们也应该有根权限,我们可以得到 sudo 就像下面一样。

$ sudo rpm -ivh iptables-utils-1.4.21-18.2.el7_4.x86_64.rpm

忽略依赖项安装

在某些情况下,系统不能满足所需的依赖关系,但我们应该安装软件包。可能是包可以工作没有问题,没有一些依赖性等,我们可以安装一个包没有依赖性与 --nodeps 选项如下。

$ sudo rpm -ivh --nodeps iptables-utils-1.4.21-18.2.el7_4.x86_64.rpm

验证是否安装了RPM软件包

安装完成后,我们可以验证指定的包是否正确安装。我们可以列出已安装的RPM软件包 -qa 选项,然后grep我们最近安装的包。在本例中,我们检查 iptables 包裹。

$ rpm -qa | grep iptables

升级RPM

如果软件包已经安装好,我们应该升级以保留现有的软件包配置。我们可以升级所有已安装的RPM软件包的新版本 -U 选项如下。

$ sudo rpm -Uvh iptables-utils-1.4.21-18.2.el7_4.x86_64.rpm

相关文章: 如何检查和查找CentOS版本?

© 版权声明
THE END
喜欢就支持一下吧,技术咨询可以联系QQ407933975
点赞0
分享