Pip ffi.h Gcc错误

京东自营,扫码进入

pip 是用于安装的工具 Python模块 从中央python存储库。使用时 pip 命令可能有一些错误,如 ffi.h gcc 。此错误如下所示。

正品S70JL128H00BAI00 S70GL02GS11FHI01 S70GL02GP12FFI01
正品S70JL128H00BAI00 S70GL02GS11FHI01 S70GL02GP12FFI01
| 月销量0件
优惠价1.3元
原价¥1.3

淘口令:

¥lCHv2PcDdtY¥
 
#include                       ^     compilation terminated.     error: command 'gcc' failed with exit status 1

安装libffi dev

这个问题与 libffi 图书馆。如果 libffi 开发库没有安装,我们会得到这个错误。要解决此问题,请安装 libffi-dev 在Debian/Ubuntu上, libffi-devel 在Redhat/Centos/Fedora上。

为Ubuntu、Debian、Mint、Kali解决

我们将安装 libffi-dev 包在基于deb的发行版中。

$ sudo apt install libffi-dev
Solve For Ubuntu, Debian, Mint, Kali
为Ubuntu、Debian、Mint、Kali解决

解决Fedora,CentOS,RedHat的问题

我们将安装 libff-devel 打包在基于rpm的发行版中。

$ sudo dnf install libffi-devel -y
Solve For Fedora, CentOS, RedHat
解决Fedora,CentOS,RedHat的问题

Pip ffi.h Gcc错误信息图

Pip ffi.h Gcc Error Infografic
Pip ffi.h Gcc错误信息图

© 版权声明
THE END
喜欢就支持一下吧,技术咨询可以联系QQ407933975
点赞0 分享