使用Pip安装特定的Python包版本

Python提供pip包管理器来安装包。默认情况下,pip包管理器将安装pip或Python包的最新版本。但是在某些情况下,您可能需要使用pip安装一个旧的或特定版本的Python包。这通常是满足依赖关系所必需的。pip安装用于安装给定Python包的特定或旧版本。

MY家 - 荷兰进口 Pip studio Royal 皇家花朵 花边餐盘/点心盘
| 月销量15件
优惠价168元
原价¥168

淘口令:

¥VopJX9B7K1F¥
 

显示Python包的最新版本

可以使用 pip3 show 命令和包名称。在下面的示例中,我们将列出numpy包的最新版本。

$ pip3 show numpy

版本 行我们可以看到当前或最新的 努比 包版本为 1.19.1 .

安装最新版本的Python包

如果我们想安装最新版本的软件包,只需向 pip3 install 命令。在下面的示例中,我们将安装最新版本的numpy包。

$ pip3 install numpy

安装特定版本的Python包

即使在默认情况下,pip install命令也会安装给定Python包的最新版本您还可以安装Python包的早期版本。为了安装Python包的早期版本或特定版本,应该使用==等号指定包版本。在下面的示例中,我们将安装 1.18 对于 努比 包裹。

$ pip3 install numpy=1.18

安装Python包的spefici版本的语法如下所示。

pip install PACKAGE==VERSION
  • 包裹 是Pip提供的正式程序包名称。
  • 版本 是将要安装的指定包的早期版本或旧版本。

从requirements.txt安装特定版本的Python包

requirements.txt用于存储将使用单个命令安装的多个包。这通常用于提供特定项目的需求。包名在requirements.txt中逐行指定,您还可以指定Python包的特定版本。requirements.txt文件内容如下所示。

numpy==1.18django==1.7WebTip==1.0

而这个requirements.txt文件的内容可以通过以下命令安装。我们将提供 要求.txt 文件与 -右 参数如下。

$ pip3 install -r requirements.txt
© 版权声明
THE END
喜欢就支持一下吧,技术咨询可以联系QQ407933975
点赞0
分享